Antbuster Bug Report

edited October 2007 in Antbuster Web Game
You saw a bug in Antbuster?

Please comment here...


  • This has happened more often than in previous versions. It seems like when the ant with a cake is trying to get back in the hole, and you concentrate the fire on the ant, and the energy is going down, sometimes you can kill it and the cake is sent back to the bottom right, but I think the game thinks that the cake went into the hole. There are been many games now where I have still two pieces of cake and the game ends. It is more regular with one piece of cake and the game ends. I'm playing version 1.2b.
  • Sometimes the missle turrets shoot in random directions.
  • And sometimes I get this box in the pause screen. What is it, Marcel Stein?
  • That box is the infamous Cheatbox. Those lousy Taiwanese people have figured out all the cheat codes, since they have nothing better to do.
  • When you use a cheat code in a cheat box, the ranking don´t accept the score...
  • Well somehow those Taiwanese are beating the system

  • Damn the Taiwanese. Cheating is a waste of time i think
  • I just experienced the same bug private described in the second posting in this thread (on Oct 27th):
    An ant had just picked up the last piece of cake when the second-last one was dropped into the hole and it was like "cake over"... After that, during the cerdits, I could watch the ant transport the last piece into the hole...
    I'm playing v1.2b.
  • I've had that happen many times mof. In addition, I've also had ants walk around with 0 health.
  • The 0 health thing isn't that uncommon- it might be rare that it occurs, but most people just ignore it.
  • actually, i lost due to the fact that an ant had 0 health left once when just figuring out the game, at a low level. it's a shame the program probably requires negative health for an ant to die. it shouldn't be that way.
  • edited December 2007
    found a setup that prevented me from placeing cannons in normally legal locations. *note the lack of a green "you can build here" box at that location....

    The black drawin in area was covering approximately the full "legal" locations (that would be not ajacent to a turret, and not ajacent to a live ant) where I "should" have been able to build, but wasn't allowed to for some unknown reason. The boundarys of the bugged area seemed to be limited to the left/right range of the level 2 poison turret, and was basically a 4x9 rectangle with the center (where the box was cut out) not known simply because I did have turrets in there BEFORE I upgraded the poison turret to level 2.

    for bug reporting: won't be interesting to most viewers, this is to help recreate the bug.

    From what I remember, I built the base poison turret first, then the 2 ice turret bases. I upgraded both turrets to heavy 1's, then the poison cannon to poison 1 before makeing anything else. after getting poison 1, I made the 2 ice turrets ice 1's, then planted the 3 turrets makeing a triangle in the middle. (the 2 side by side, and the one right uneder it). when they were all heavy 2's, I upped one of them (the one on the left, I think) to a missle launcher, upped the poison to poison 2, then upped the other 2 center turrets to missle1's. This is right before I found the glitch. I tried to build to the left of the turret, failed miserably a few times, and accidentally built above it while trying to target an ant with cake. after that, I jsut tried to find locations where I couldn't build, but should have been able to while letting the ants do whatever they wanted, and getting at least one screen shot of it.

    My first attempt to reproduce this failled, but I wanted to get it down before I got too confused on orders of things I did. I'll edit this if I can get it to do this again.
  • this is not about the game, but for some reason, some forum acounts say 0 visits, but have started discussions or added comments. How is this possibel?
  • somehow the site seems to have crashed or something. for some reason, i have to go directly to this forum. i go to, and it doesn't have the normal stuff. i went to google translater, and tried translating it. it said: " There was an error retrieving information from games."

    their is a cheat box!!!!!
  • edited December 2007
    Everyone knows of that, alf. The only people willing to use it are the Taiwanese (lousy jerks) and those who will do ANYTHING to beat the Taiwanese.
  • edited December 2007
    Private and Mof, i have had the same problem, hope i get's fixed i was about to beat my record big time and get a second misle launcher2 XD was already up 3lvl from my top score, still only 64 though =p oi also right before i got lvl70 so close lvl69 and i glitched to death my friend who was with me was like "omg wtf?!?!!~~~!!? waz U Haxed ouuutt o dAT sk1LLs score?!?! damn taiwanese!! D3MS F00LS HAX3D UUUU!!!!" it was funny, he's a loon.
  • edited December 2007
    it happened again! at lvl61 i watched them take the last piece o' cakady-pie (my word for the cake/pie) too bad i would of got a small bit further, it's easier to gaurd one piece of cakady-pie where youc an concentrate all fire power on it, and have no worries of letting others slip while doing so.

    and actully when you use that cheat box your score doesn't register, only if you hack he cheated scores in to the ranking does it work, so yes they hack, but the cheat box it's self is not at fault. Thanks goes to marcel for clearing that up for us ^^

    Ok i have it down to a science now, if you ahve 2pieces left and 1 ant that has it is still on the cakady-pie mat (the checkered place where you cant put cannons) and the other makes it to hole you lose even if you still have that 1 ant that could with the cakady-pie.
    But still that amkes it 2 times in one day
  • edited December 2007
    and another, i was playing today and i had a ice cannon hitting a targeted ant but wouldn't slow it kept goging and actully gto faster. like on fire.
    after that the ice slowed them down again, happened only once, maybe a 1time thing
  • edited December 2007
    i added a picture to my posts but it wont show up and a picture to my account which also wont show up. Does it have to be from that site you offered as an example marcel? Or is that an actully place.
    I think it would be helpful if you could html it. Or forum code it in

Leave a Comment

BoldItalicStrikethroughOrdered listUnordered list
Attach file
Attach image
Align leftAlign centerAlign rightToggle HTML viewToggle full pageToggle lights
Drop image/file